Hedgehog Central banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hey, I'm picking up my little girl tomorrow, so I figured I'd give the heating aspect of her cage a test run tonight (everything only just arrived today... vet bills have delayed my purchases). Anyway, I have a few questions:

I ordered off Amazon, and ordered what I thought was a regular old 100 watt CHE, and an 8.5 in clamp lamp. Well upon opening the bulb, it says to only use with a certain kind of lamp that I didn't purchase. I didn't realize this til I screwed the bulb in, and now it appears to be stuck. I plugged it in and turned it on, it still works, should I try to get it out and get a different CHE? I've never used this kind of heating element before, so when it was a little difficult to screw in I thought it was just finicky.

It also seems to smell. I'm not sure if its the bulb, the fact that it is new, or the metal shelf I have it sitting on. I can post a picture tomorrow, but I built a shelf over the cage made out of those storage cubes since I'll be using a sterilite bin to start.

I'm just concerned about setting fire to my apartment, I've been to enough of those that I don't need to experience it first hand. :shock:
 

·
Registered
Joined
·
695 Posts
I would probably try to replace either the bulb or the lamp. Not worth the risk of something going wrong! It also might not work as efficiently and you don't want to find that out after it's too late. I got my whole setup at PetSmart if you don't have time to exchange your items online. Not sure if that smell has anything to do with it but that would probably make me a bit nervous as well. Just my opinion!

Sent from Petguide.com Free App
 

·
Registered
Joined
·
1,922 Posts
No idea what bulb or lamp you're using, so no idea if it's a safe combo. Photos and exact names would probably help.

But: yes, CHEs can sometimes give off a weird smell when first turned on. If it's a particularly strong smell, or lasts a long time, or smells like burning, something is definitely wrong.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
The bulb is item #CE-100 and the lamp is #LF-12, both ZooMed. I'm going to stop it Petsmart today and just get another set and figure this one out later.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
Yes, it says it's for a CHE. When I read the little package that came with the bulb it says "Using this bulb with any product other than LF-10 may void the warranty." LF-10 is the wire clamp lamp, I guess I didn't realize it wouldn't also fit in the dome clamp lamp? Lesson learned. I'm going to try to get the bulb out to return it, eventually I'll need two lamps anyway when I give her more space. I bought another one at Petsmart this morning, it just doesn't have the clamp which I don't prefer.

http://www.thatpetplace.com/zoo-med..._id=26455423&gclid=COLsq-fupL0CFcg7OgodKy4A7w
 
1 - 6 of 6 Posts
Top