Hedgehog Central Hedgehog pet care & owner forum - Reply to Topic
Hedgehog Central GalleryForum Archives Facebook Link

Thread: CHE problem Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Hedgehog Central Hedgehog pet care & owner forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-13-2013 05:16 PM
HedgehogsInc. The lamp is fit for the bulb, I've checked before I bought the CHE. I was actually thinking about getting the Zoo Med bulbs, but I thought Fluker's would be more reliable, apparently I was wrong. I'm still wondering if I should call Amazon or Fluker's about this.
11-13-2013 04:54 PM
abbys I use the Zoo Med CHE bulbs and they've held up for about 10 months now. I once had a problem with the actual lamp because it was just a 5.5" lamp and couldn't handle the 100w bulb. Double check to make sure your lamp is built for a 150w bulb. If not, that could be the problem.
11-13-2013 04:36 PM
HedgehogsInc.
CHE problem

After I redid all of Harvey's cage, I also got him a new heating bulb in case the red one bothered him. I bought the 150 watt Fluker's Ceramic Heat Emitter off of Amazon and it seemed to be working fine until like 2 weeks ago. When I was reading the comments off of Amazon, there were both good and bad, so I decided to buy it. Turns out I've got one that doesn't work after a couple of months.
At first I went to see if it was the temperature controller, but it's not. When I unplugged the heating lamp from the temperature controller and plugged it into to the wall outlet it still stayed around 69-71 degrees. I'm really worried about Harvey because he might go into hibernation. I'm thinking about calling Amazon about this, but the return date for the CHE is expired. What should I do? And can anyone recommend a good CHE?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:01 PM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
PetGuide.com
Basset Hound Forum Doberman Forum Golden Retriever Forum Beagle Forum
Boxer Forum Dog Forum Pit Bull Forum Poodle Forum
Bulldog Forum Fish Forum Havanese Forum Maltese Forum
Cat Forum German Shepherd Forum Labradoodle Forum Yorkie Forum Hedgehog Forum
Chihuahua Forum Cichlid Forum Dart Frog Forum Mice Breeder Forum