Revolution not working? - Hedgehog Central Hedgehog pet care & owner forum
Hedgehog Central GalleryForum Archives Facebook Link

Reply
 
LinkBack Thread Tools
Old 09-27-2018, 01:26 AM   #1 (permalink)
Junior Member
 
mjuikoli's Avatar
 
Join Date: Sep 2018
Posts: 4
Default Revolution not working?

Good day!

I recently took my hedgie last week for a check-up because I just recently got her, and we found out that she had mites. The vet immediately used Revolution to treat her mites. She used just a drop because dosage is measured by weight. However, it has been a week since that vet visit and my poor hedgehog is still scratching and still continuing to lose quills.

I don't know if I should wait or apply Revolution again (the vet made me take home the rest of the Revolution).

Please help
mjuikoli is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-27-2018, 06:31 AM   #2 (permalink)
Member
 
Yukidama's mama's Avatar
 
Join Date: Apr 2017
Location: Tokyo, Japan
Posts: 815
Default

Hi, I'd follow the vets instructions. Normally doses are two weeks apart and can take 2 or 3 doses to complete the course and kill the remaining ones, since new eggs will hatch in between doses.

You could call your vet and just let them know she is still scratching etc and see what they say and re-confirm when to apply the second dose.

Hoping she recovers soon!
Yukidama's mama is offline   Reply With Quote Quick reply to this message
Reply

Tags
mites

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hedgehog Central Hedgehog pet care & owner forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in




Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Revolution not working, told I need Ivermection AngelaH Mites 4 03-08-2014 06:16 PM
I don't think the Revolution is working. Viki Health 3 09-16-2012 01:30 PM
help, thermostat not working properly repti temp v.bow Heating 10 10-26-2011 02:36 AM
Hedgehog Grove not working... OwlCity19 Diet and Nutrition 4 03-25-2011 06:11 PM
CHE not working?!? emilylucy Heating 8 01-31-2011 02:28 PM


All times are GMT -4. The time now is 03:21 PM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
PetGuide.com
Basset Hound Forum Doberman Forum Golden Retriever Forum Beagle Forum
Boxer Forum Dog Forum Pit Bull Forum Poodle Forum
Bulldog Forum Fish Forum Havanese Forum Maltese Forum
Cat Forum German Shepherd Forum Labradoodle Forum Yorkie Forum Hedgehog Forum
Chihuahua Forum Cichlid Forum Dart Frog Forum Mice Breeder Forum