Burning? - Hedgehog Central Hedgehog pet care & owner forum
Hedgehog Central GalleryForum Archives Facebook Link

Reply
 
LinkBack Thread Tools
Old 03-04-2019, 08:50 PM   #1 (permalink)
Member
 
Sylvester7812's Avatar
 
Join Date: Feb 2018
Posts: 53
Default Burning?

So I finally got Sylvester the heating set he needs (the Che bulb, lamp, thermostat, and thermometer) and I got it all set up but it smells like it’s burning kind of. The temp says 76 but I’m kind of nervous. There’s also a jingling noise coming from the bulb. Is this normal for a new lamp and bulb?
Sylvester7812 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-04-2019, 09:36 PM   #2 (permalink)
Member
 
Join Date: Oct 2018
Location: southern Il. USA
Posts: 320
Default

There can be a burning smell the first time you turn on a new bulb and holder. Kind of like when you turn on the furnace the first time in the fall. Is the noise when you wiggle it or when it is not being moved? I have had lamp holders that the center contact needed bent up a little to get a good connection with the bulb. BUT BE VERY CAREFULL AND MAKE SURE THE HOLDER IS UN PLUGGED!! Some times when the conection is not good you can hear a sizzleing noise from the electric arking.
belties is offline   Reply With Quote Quick reply to this message
Old 03-04-2019, 10:15 PM   #3 (permalink)
Member
 
Sylvester7812's Avatar
 
Join Date: Feb 2018
Posts: 53
Default

The noise is happening when it’s on and heating up without movement
Sylvester7812 is offline   Reply With Quote Quick reply to this message
 
Old 03-04-2019, 10:19 PM   #4 (permalink)
Member
 
Aj.t's Avatar
 
Join Date: Jan 2019
Posts: 468
Default

Hey there! The burning smell is a common occurrence, like was stated earlier, especially if there was dust on or around the bulb/lid. I would be concerned about the rattling sound though... I’m like the LAST person to ask about anything electrical though so we’ll wait for some other people to chime in lol
Aj.t is offline   Reply With Quote Quick reply to this message
Old 03-04-2019, 10:27 PM   #5 (permalink)
Member
 
Join Date: Oct 2018
Location: southern Il. USA
Posts: 320
Default

Some of them will make a little sound as they come up to full heating temp from the element on the inside expanding as it gets hot .Does the noise continue after it is on for several minutes? If so you may have a defective element. It's not to common but does happen.
belties is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hedgehog Central Hedgehog pet care & owner forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in




Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 06:13 PM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
PetGuide.com
Basset Hound Forum Doberman Forum Golden Retriever Forum Beagle Forum
Boxer Forum Dog Forum Pit Bull Forum Poodle Forum
Bulldog Forum Fish Forum Havanese Forum Maltese Forum
Cat Forum German Shepherd Forum Labradoodle Forum Yorkie Forum Hedgehog Forum
Chihuahua Forum Cichlid Forum Dart Frog Forum Mice Breeder Forum