Amoxicillin not working? - Hedgehog Central Hedgehog pet care & owner forum
Hedgehog Central GalleryForum Archives Facebook Link

Reply
 
LinkBack Thread Tools
Old 02-04-2013, 06:41 AM   #1 (permalink)
Member
 
Join Date: Sep 2010
Posts: 120
Talking Amoxicillin not working?

Hi everyone!

Sandy was put on amoxicillin for what the vet diagnosed as a GI infection of some kind. We started it Friday night, and he's been getting it morning and night since then. Before bed, I also give him some herbivore/carnivore care mixed with some squash baby food (since he loves that and it makes it easier to get it in him) and some water. He seems himself, but still isn't doing very well.

He went from having all green mucousy poops on Friday to having half normal, half green mucousy poops today. It's been gradually getting a bit better. However, last night he went to eat some of his kibble (yay!) and there's two little spots of vomit on his fleece. He had one little normal-ish looking poop and two really mucousy forest green ones. I'm just looking for some possibilities at what's going on. He's keeping his squash and water down, so that's comforting for sure. But could the amoxicillin be upsetting his stomach? Or could it be because all the squash and herbivore/carnivore care are new to his diet? Basically, I'm wondering whether I should be concerned that he's still pooping funny and throwing up.

I'm probably just an impatient mom and wanting the antibiotics to hurry up but I was really hoping for some thoughts from anyone who's had experience with amoxicillin or GI infections.

Thank you so much!
Galvon is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-04-2013, 08:31 AM   #2 (permalink)
Hooked on Hogs
 
Join Date: Aug 2008
Location: Kingston, Ontario
Posts: 8,950
Default Re: Amoxicillin not working?

He possibly needs a stronger or different antibiotic. The amoxicillin may have worked well enough to start clearing up the infection which is why you saw improvement, but it's not enough to completely cure it. I'd phone the vet and tell him/her whats happening.
__________________
* * * Nancy * * *

Retired from breeding

Rescue contact for both the Hedgehog Welfare Society and the IHA
Rescued over 70 (and counting) hedgehogs needing a new home


http://freewebs.com/thehedgieden/
Nancy is offline   Reply With Quote Quick reply to this message
Old 02-04-2013, 09:17 AM   #3 (permalink)
Member
 
Join Date: Sep 2010
Posts: 120
Default Re: Amoxicillin not working?

Thanks so much nancy! Ill definitely do that. Here's hoping for normal poops tomorrow!
Galvon is offline   Reply With Quote Quick reply to this message
 
Old 02-04-2013, 01:34 PM   #4 (permalink)
Member
 
Mommatobe's Avatar
 
Join Date: Apr 2012
Location: Ontario, Canada
Posts: 179
Default Re: Amoxicillin not working?

My Emma just went through a "bout" of green mucousy poop and the green colour only started to subside after she was put on baytril (was on clavamox for ~ 4 days before baytril was started). Like Nancy said he may just need a stronger anti-biotic. Even with both meds it took almost a week before she started to have normal coloured BMs and was eating on her own. (was also feeding the herbivore/carnivore mix)...goodluck, let us know how it goes!
__________________
Mommatobe is offline   Reply With Quote Quick reply to this message
Old 02-05-2013, 11:34 AM   #5 (permalink)
Member
 
Join Date: Sep 2010
Posts: 120
Default Re: Amoxicillin not working?

Hmm thanks for the insight mommatobe! We're going back to the vet today so maybe ill suggest baytril. Did you keep Emma on both medications at the same time? Also clavamox is more or less amoxicillin, right? So maybe a combination of amoxicillin and baytril can beat this thing!

Thanks for the tip we'll keep you posted
Galvon is offline   Reply With Quote Quick reply to this message
Old 02-05-2013, 09:54 PM   #6 (permalink)
Member
 
Mommatobe's Avatar
 
Join Date: Apr 2012
Location: Ontario, Canada
Posts: 179
Default Re: Amoxicillin not working?

Yes Emma was on both at the same time and Clavamox does have amoxicillin in it. Let us know how it goes! Goodluck!
__________________
Mommatobe is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hedgehog Central Hedgehog pet care & owner forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in




Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is my CHE not working or what? Folly Heating 7 01-18-2013 09:38 PM
I don't think the Revolution is working. Viki Health 3 09-16-2012 01:30 PM
CHE not working?!? emilylucy Heating 8 01-31-2011 02:28 PM
Amoxicillin and gentamicin side effects? PLEASE HELP shadowlynx Health 1 12-26-2010 01:05 PM
Thermostat Working? hedgeowl Heating 4 01-01-2010 02:05 AM


All times are GMT -4. The time now is 12:11 PM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
PetGuide.com
Basset Hound Forum Doberman Forum Golden Retriever Forum Beagle Forum
Boxer Forum Dog Forum Pit Bull Forum Poodle Forum
Bulldog Forum Fish Forum Havanese Forum Maltese Forum
Cat Forum German Shepherd Forum Labradoodle Forum Yorkie Forum Hedgehog Forum
Chihuahua Forum Cichlid Forum Dart Frog Forum Mice Breeder Forum